Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9682

Can't restore quiz questions, nor add questions to the restored EMPTY quizes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not a bug
    • Affects Version/s: 1.6.2
    • Fix Version/s: 1.7, 1.8
    • Component/s: Backup, Quiz
    • Labels:
      None
    • Environment:
      Moodle 1.6.2+ (2006050521) on LAMP using IE
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      The backup (see attachment) created empty quizes despite the fact that there were about 120 questions and it even says so in the restore.

      This is quite a problem for me since I rely on back up and restore of quizes.

      In more detail.

      I have three courses Monday, Wednesday and Thursday with lots of quizes. Normally I created the quizes in monday's course and then move them to Wed and then Fri.

      There was a Monday bank holiday recently, so I created the categories and questions in Monday, making them "public" as usual, since I wanted to keep the home of all the categories in one place. I then created the quizes in Wednesday, backed them up and moved them to friday. All was fine.

      Then this morning I backed up the quizes again in Wednesay to move to Monday. I first of all restored them in a dummy course because I wanted to move the week (the bank holiday meant that the Monday week is the 3rd not the 2nd). This works okay but takes AGES - about three minutes even though I am only restoring one week (8 quizes, 125 questions 50 categories). The questions are there.

      Then I backup this dummy course and restore it to Monday.

      The quizes are created but there are NO questions inside them.

      Also when I try and add questions to the quizes thus created, I press the "add a random question" button and nothing happens. No question is added.

      Bear in mind that the categories and questions were created and remain extant in Monday and I guess that this is the cause of the error.

      In other words, this bug is PERHAPS "quizes using publically available questions can not be reimported into the quiz from which the questions and categories came. "NOOOO!

      Hold on! Looking inside the backup it seems that the questions are not even there only the quizes. So it is not surprising that that the questions did not appear.

      I have no idea how I managed to backup quizes without their questions....

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                timhunt Tim Hunt
                Reporter:
                nexus Nexus Learning
                Tester:
                Nobody
                Participants:
                Component watchers:
                Adrian Greeve, Mihail Geshoski, Peter Dias, Tim Hunt, Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  7/Nov/06