Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9702

Custom user profile fields on the signup page

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9
    • Component/s: Authentication
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Creating an issue here to keep track of progress.

      The original plan was to have required custom user profile fields appear in the signup page. However currently the signup page does not include all the standard required fields, only the bare minimum to create an account in moodle so the custom profile fields have not (yet) been included.

      A possible solution might be to have another flag against every custom profile field indicating if it should be included in the signup page or not.

      Related: MDL-9285
      Docs: http://docs.moodle.org/en/Development:Customisable_user_profiles

        Gliffy Diagrams

          Issue Links

            Activity

            ikawhero Shane Elliott added a comment -

            New database fields have been added for 1.9. Interface changes coming.

            dougiamas Martin Dougiamas added a comment -

            Can we close this? :-P

            ikawhero Shane Elliott added a comment -

            Yes, done in 1.9

            ikawhero Shane Elliott added a comment -

            This is a duplicate of MDL-8800.
            Closing both as code is now in 1.9


              People

              • Votes:
                18 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Mar/08