Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9730

missing link to PDF page if plug-in is not present

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8.1
    • Component/s: Resource
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      I do confrm the bug MDL-9721 but I am filling this new bug in order to increase the priority.
      Add a PDF document to a course as "Link to a file or web site" with
      -> "Window" = same window
      and
      -> "Keep page navigation visible on the same page" checkbox selected.

      If the user doesn't have the plug-in to open the PDF inside the internet browser, the PDF page appear empty and on the top of the content free page is written: "To open this document, click on this link:" BUT THE LINK IS NOT PRESENT

      This bug is new. It was perfectly working few weeks ago.

        Gliffy Diagrams

        1. investigation.html
          1 kB
          Daniele Cordella
        1. Immagine-1.gif
          7 kB
        2. Immagine 1.png
          15 kB

          Issue Links

            Activity

            daniss Daniele Cordella added a comment -

            I tested it on April 6 after the closure of the bug MDL-9198 and all was working fine.

            daniss Daniele Cordella added a comment -

            attached is the output of my investigation (in html format) about this error that is blocking courses because PDF resources are totally not available.

            daniss Daniele Cordella added a comment -

            in my html attachment
            what I do call "10 days old moodle" is a local Moodle installation I made on last April 20
            what I do call "just downloaded moodle" is a local Moodle installation I made on last May 4
            Sorry for my not exact definitions.

            andreabix Andrea Bicciolo added a comment -

            Tested, the problem is still present. Probably it is trivial to solve. Nicolas?

            nicolasconnault Nicolas Connault added a comment -

            Tested this issue on the following browser/OS combinations:

            Windows:

            • IE 3, 4, 5, 5.5, 6, 7
            • Firefox 2.0.0.3
            • Opera 9

            Linux:

            • Firefox 2.0.0.3
            • Flock 0.7.11
            • Konqueror

            On a server running

            • Apache 2.0
            • PHP 4.4.2
            • MySQL 5.0.27

            Result: Could not replicate issue. Link appeared as normal when plugin was missing. PDF document appeared as normal when plugin present.

            andreabix Andrea Bicciolo added a comment -

            Nicolas, thanks for the report. Now I found how to reproduce the problem, and it appears when resource has missing description. So the issue would be changed to:

            "missed link to pdf pages (when plugin is not present and keep navigation is true) when resource description is missing"

            This should lead to two possible options to avoid problems:

            1. keep the resource description mandatory (probably not very good)
            2. when description is null, link text shall default to the resource name, which is already mandatory.

            What do you think?

            skodak Petr Skoda added a comment -

            fixed in cvs, name is now used instead of summary which is already printed bellow the link
            thanks for the report!

            daniss Daniele Cordella added a comment -

            thank you Petr.
            Whay did you fix it in 1.9 only. It is important enought for 1.8 too, don't you think so?

            daniss Daniele Cordella added a comment -

            I am sorry, Petr. I just found it in 1.8 nightly. Why it didn't appear in this page that you made changes to 1.8 too?

            skodak Petr Skoda added a comment -

            it takes some time before Jira parses the cvs tree


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jun/07