Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9819

Problems with Numerical Question Restores

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7.2
    • Fix Version/s: None
    • Component/s: Questions, Quiz
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE

      Description

      Numerical questions aren't restoring correctly.

      In 1.7 the answer seems to be missing, prevent the whole quiz from loading.

      In 1.8+ the quiz can be viewed, but the calculated question text isn't viewable.

      I've attached a backup file to demonstrate the problem.

        Gliffy Diagrams

          Issue Links

            Activity

            poltawski Dan Poltawski added a comment -

            I think that this change not being applied to MOODLE_17_STABLE is the cause of the issues with the 1.7 restore:
            http://moodle.cvs.sourceforge.net/moodle/moodle/question/type/numerical/questiontype.php?r1=1.9&r2=1.10

            poltawski Dan Poltawski added a comment -

            Ooops, actually the non 1.7 problems are the fault me not putting question text in..

            poltawski Dan Poltawski added a comment -

            Fixed the issues with 1.7 in CVS

            skodak Petr Skoda added a comment -

            Could you please review the MOODLE_17_MERGED tag and merging into other branches?
            thanks

            poltawski Dan Poltawski added a comment -

            Hi Petr,

            I've updated the MOODLE_17_MERGED tag, apologies about that..

            MOODLE_18_STABLE & HEAD should have the change in already as the above change was made before the branch for 18.

            Please let me know if i've missed anything.

            skodak Petr Skoda added a comment -

            I think it was after the branching - because all files are tagged immediately after the branching

            I did not find it in 18 and HEAD, could you please verify it again?

            poltawski Dan Poltawski added a comment -

            Hmm, I have removed that code from 17, and its also been removed from HEAD and 18 as far as I can see (lines 444 in HEAD & 479 in 18_STABLE) ?

            skodak Petr Skoda added a comment -

            I know very little about this code myself


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: