Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9952

Cant escape # by using \ in a Cloze question

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.2
    • Fix Version/s: 1.8.3, 1.9
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      MY SQL 5.0.24; PHP 4.3.10; Windows IIS; Windows Server 2003
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      I want music students to identify notes in a musical scale with a CLOZE question type.
      Example: Question should read: What are the notes in a D major scale? Answer should read: D E F# G A B C# D but instead reads D E F G A B C D. I tried using a double
      and this worked sometimes but was only good for one edit (it seems each time the question was updated, one \ was removed. Very often, the question would not update at all with messages " could not update question" and "could not insert new question"

      Code I write is is attatched.

        Attachments

          Activity

            People

            Assignee:
            timhunt Tim Hunt
            Reporter:
            williamsr Rick Williams
            Tester:
            Nobody
            Participants:
            Component watchers:
            Tim Hunt, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              11/Oct/07