Uploaded image for project: 'Moodle QA'
  1. Moodle QA
  2. MDLQA-1190 Moodle 2.2 QA
  3. MDLQA-1411

CLONE - An administrator can install additional language packs

    Details

      Description

      1. Login as an administrator and browse to Settings > Site administration > Language > Language packs.
      2. Select select several languages from the list of available languages and click the 'Install selected language pack' button.
      3. Check that the languages are now listed as installed language packs.
      4. Select an installed language pack and click the 'Uninstall selected language pack' button.
      5. Check than the language is now listed as an available language.
      6. Make a note of the currently installed language packs and then browse to the site front page.
      7. Check that the languages are listed in the dropdown menu at the top right of the site front page.
      8. Browse to your edit profile page and check that the languages are available in the preferred language setting.

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            ankit_frenz Ankit Agarwal added a comment -

            Hi,

            • I am getting following warning when trying to install a pack on QA site

              Warning: fopen(/moodledata/temp/.htaccess) [function.fopen]: failed to open stream: No such file or directory in /html/lib/setuplib.php on line 1153

              Al tough the pack gets installed properly. This might be a simple permission issue but needs to be investigated anyway.

            • This test should be updated to include instructions to also do "update all language packs"
              Thanks
            Show
            ankit_frenz Ankit Agarwal added a comment - Hi, I am getting following warning when trying to install a pack on QA site Warning: fopen(/moodledata/temp/.htaccess) [function.fopen]: failed to open stream: No such file or directory in /html/lib/setuplib.php on line 1153 Al tough the pack gets installed properly. This might be a simple permission issue but needs to be investigated anyway. This test should be updated to include instructions to also do "update all language packs" Thanks
            Hide
            tsala Helen Foster added a comment -

            Ankit, thanks for your comments. I have updated the master copy of this test as you suggest.

            Show
            tsala Helen Foster added a comment - Ankit, thanks for your comments. I have updated the master copy of this test as you suggest.
            Hide
            mina Nicolas Martignoni added a comment -

            This test works perfectly on my own 2.2beta own server.

            Show
            mina Nicolas Martignoni added a comment - This test works perfectly on my own 2.2beta own server.
            Hide
            ankit_frenz Ankit Agarwal added a comment -

            passing this since MDLSITE-1572 fixed all related issues.
            Thanks

            Show
            ankit_frenz Ankit Agarwal added a comment - passing this since MDLSITE-1572 fixed all related issues. Thanks

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: