Uploaded image for project: 'Moodle QA'
  1. Moodle QA
  2. MDLQA-1 Moodle QA testing
  3. MDLQA-16086

An admin can install Moodle using a predefined admin preset

    XMLWordPrintable

Details

    • Functional Test
    • Minor
    • None
    • Original - DO NOT REPORT TEST RESULTS HERE
    • Administration

    Description

      IMPORTANT: As all these installations will be run against the same code and database, it's important to use a different dbprefix. The testing instructions have been written taking this into account (so this is just a warning in case you copy&paste the command without changing this value).

      You might need to give read permission to your config.php if you see some errors about permission denied

      Testing scenario 1. CLI install: Apply STARTER

      1. Remove config.php if it exists.
      2. Remember to use an empty database or a new prefix.
      3. Open a terminal and run the following command. You'll probably need to modify some values, such as wwwroot, dbname, dbuser and dbpass to your local installation: 
        php admin/cli/install.php --lang=en --wwwroot=http://localhost/m/integration_master --dbtype=pgsql --dbname=integrationmaster --dbuser=postgres --dbpass=postgres --prefix=aa_ --fullname=Test --shortname=Test --adminpass=test --adminemail=admin@moodle.invalid --sitepreset=starter --agree-license --non-interactive --allow-unstable

       

      1. Check the installation process finishes without errors.
      2. Open the config.php and check it contains $CFG->setsitepresetduringinstall = 'starter'.
      3. Login as admin.
      4. Go to "Site administration > Site admin presets".
      5. Check the "Show version history" option is displayed in the "Starter" actions menu.
      6. Go to "Site administration > Advanced features".
      7. Check "Enable comments", "Enable tags functionality", "Enable notes", "Enable blogs", "Enable badges" and "Enable competencies" features are disabled.
      8. Go to "Site administration > Plugins > Manage activities".
      9. Check, at least, Database, Lesson and Wiki are disabled.

      Testing scenario 2. CLI install: Apply a non-existing preset

      1. Remove config.php if it exists.
      2. Remember to use an empty database or a new prefix.
      3. Open a terminal and run the following command. You'll probably need to modify some values, such as wwwroot, dbname, dbuser and dbpass to your local installation: 
        php admin/cli/install.php --lang=en --wwwroot=http://localhost/m/integration_master --dbtype=pgsql --dbname=integrationmaster --dbuser=postgres --dbpass=postgres --prefix=bb_ --fullname=Test --shortname=Test --adminpass=test --adminemail=admin@moodle.invalid --sitepreset=unexisting --agree-license --non-interactive --allow-unstable

       

      1. Check the installation process finishes without errors.
      2. Open the config.php and check it contains $CFG->setsitepresetduringinstall = 'unexisting'.
      3. Login as admin.
      4. Go to "Site administration > Site admin presets".
      5. Check the "Show version history" option is NOT displayed in the "Starter" actions menu.
      6. Go to "Site administration > Advanced features".
      7. Check all the settings have their default value (except for enablewebservices which is enabled by default if site is https and not if http)
      8. Go to "Site administration > Plugins > Manage activities".
      9. Check Database, Lesson and Wiki are enabled.

      Testing scenario 3. CLI install: Import valid XML file

      1. Remove config.php if it exists.
      2. Remember to use an empty database or a new prefix.
      3. Open a terminal and run the following command. You'll probably need to modify some values, such as wwwroot, dbname, dbuser and dbpass to your local installation (use the absolute path to the --sitepreset option): 
        php admin/cli/install.php --lang=en --wwwroot=http://localhost/m/integration_master --dbtype=pgsql --dbname=integrationmaster --dbuser=postgres --dbpass=postgres --prefix=cc_ --fullname=Test --shortname=Test --adminpass=test --adminemail=admin@moodle.invalid --sitepreset=/home/user/moodles/m/integration_master/moodle/admin/presets/tests/fixtures/import_settings_plugins.xml --agree-license --non-interactive --allow-unstable

       

      1. Check the installation process finishes without errors.
      2. Open the config.php and check it contains $CFG->setsitepresetduringinstall = '/home/user/moodles/m/integration_master/moodle/admin/presets/tests/fixtures/import_settings_plugins.xml'.
      3. Login as admin.
      4. Go to "Site administration > Site admin presets".
      5. Check a 3 presets are displayed: "Starter", "Full" and "Imported preset".
      6. Check the "Show version history" option is displayed in the "Imported preset" actions menu.
      7. Go to "Site administration > Plugins > Manage activities".
      8. Check, Chat and Database are disabled and Lesson is enabled.

      Testing scenario 4. CLI install: Import unexisting XML file

      1. Remove config.php if it exists.
      2. Remember to use an empty database or a new prefix.
      3. Open a terminal and run the following command. You'll probably need to modify some values, such as wwwroot, dbname, dbuser and dbpass to your local installation (use the absolute path to the --sitepreset option):  
        php admin/cli/install.php --lang=en --wwwroot=http://localhost/m/integration_master --dbtype=pgsql --dbname=integrationmaster --dbuser=postgres --dbpass=postgres --prefix=dd_ --fullname=Test --shortname=Test --adminpass=test --adminemail=admin@moodle.invalid --sitepreset=/home/user/moodles/m/integration_master/moodle/admin/presets/tests/fixtures/xxxxx.xml --agree-license --non-interactive --allow-unstable

       

      1. Check the installation process finishes without errors (there are some warnings, but no errors).
      2. Open the config.php and check it contains $CFG->setsitepresetduringinstall = '/home/user/moodles/m/integration_master/moodle/admin/presets/tests/fixtures/xxxxx.xml'.
      3. Login as admin.
      4. Go to "Site administration > Site admin presets".
      5. Check only 2 presets are displayed: "Starter" and "Full".
      6. Go to "Site administration > Plugins > Manage activities".
      7. Check, Database, Lesson and Wiki are enabled. 

      Testing scenario 5. CLI install: Import invalid XML file

      1. Remove config.php if it exists.
      2. Remember to use an empty database or a new prefix.
      3. Open a terminal and run the following command. You'll probably need to modify some values, such as wwwroot, dbname, dbuser and dbpass to your local installation: 
        php admin/cli/install.php --lang=en --wwwroot=http://localhost/m/integration_master --dbtype=pgsql --dbname=integrationmaster --dbuser=postgres --dbpass=postgres --prefix=ee_ --fullname=Test --shortname=Test --adminpass=test --adminemail=admin@moodle.invalid --sitepreset=/home/user/moodles/m/integration_master/moodle/admin/presets/tests/fixtures/invalid_xml_file.xml --agree-license --non-interactive --allow-unstable

       

      1. Check the installation process finishes without errors (in that case, as the XML is invalid, some warning might be raised, depending on your server configuration).
      2. Open the config.php and check it contains $CFG->setsitepresetduringinstall = '/home/user/moodles/m/integration_master/moodle/admin/presets/tests/fixtures/invalid_xml_file.xml'.
      3. Login as admin.
      4. Go to "Site administration > Site admin presets".
      5. Check only 2 presets are displayed: "Starter" and "Full".
      6. Go to "Site administration > Plugins > Manage activities".
      7. Check, Database, Lesson and Wiki are enabled. 

      Testing scenario 6. CLI install: Default installation (without --sitepreset)

      1. Remove config.php if it exists.
      2. Remember to use an empty database or a new prefix.
      3. Open a terminal and run the following command. You'll probably need to modify some values, such as wwwroot, dbname, dbuser and dbpass to your local installation: 
        php admin/cli/install.php --lang=en --wwwroot=http://localhost/m/integration_master --dbtype=pgsql --dbname=integrationmaster --dbuser=postgres --dbpass=postgres --prefix=ff_ --fullname=Test --shortname=Test --adminpass=test --adminemail=admin@moodle.invalid --agree-license --non-interactive --allow-unstable

       

      1. Check the installation process finishes without errors.
      2. Open the config.php and check it does NOT contain $CFG->setsitepresetduringinstall.
      3. Login as admin.
      4. Go to "Site administration > Site admin presets".
      5. Check the "Show version history" option is not displayed in the "Starter" nor the "Full" actions menu.
      6. Go to "Site administration > Advanced features".
      7. Check "Enable comments", "Enable tags functionality", "Enable notes", "Enable blogs", "Enable badges" and "Enable competencies" features are enabled.
      8. Go to "Site administration > Plugins > Manage activities".
      9. Check, at least, Database, Lesson and Wiki are enabled.

      Testing scenario 7. Manual install: Apply STARTER

      1.  Edit the config.php file and change the following fields:
        • $CFG->prefix = 'gg_';
        • $CFG->setsitepresetduringinstall = 'starter';
      2. Go to the Moodle site and follow the installation process, pressing the "Continue" button, to installing manually your Moodle site.
      3. Once the installation process finishes and all the required forms are filled-out, go to "Site administration > Site admin presets".
      4. Check the "Show version history" option is displayed in the "Starter" actions menu.
      5. Go to "Site administration > Advanced features".
      6. Check "Enable comments", "Enable tags functionality", "Enable notes", "Enable blogs", "Enable badges" and "Enable competencies" features are disabled.
      7. Go to "Site administration > Plugins > Manage activities".
      8. Check, at least, Database, Lesson and Wiki are disabled.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:

                Clockify

                  Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.