Uploaded image for project: 'Moodle QA'
  1. Moodle QA
  2. MDLQA-325 Moodle QA non-runners
  3. MDLQA-1790

An admin can upgrade from Moodle 2.2 with mod_book installed to Moodle 2.3 without errors

    XMLWordPrintable

    Details

    • Type: Functional Test
    • Status: Open
    • Affects Version/s: Moodle QA non-runners
    • Fix Version/s: None
    • Component/s: Book
    • Labels:
      None

      Description

      Test notes:

      This QA test only needs to be present in the 2.3 QA cycle, when the mod_book is landing to core. Must be deleted as subtask of MDLQA-1 once the cycle is over.

      Test pre-requisites:

      • Any Moodle 2.2.x installed
      • mod_book from contrib installed
      • at least one book activity created with 2-3 chapters/subchapters containing some image.

      Test steps:

      1. Install Moodle 2.3 codebase and, as admin, proceed to upgrade.
      2. The process ends without any error related with mod_book.
      3. Access to the book activity created under Moodle 2.2. The chapters and their contents (with images) continue there.

        Attachments

          Activity

            People

            Assignee:
            nobody Nobody
            Participants:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated: