Moodle Community Sites
  1. Moodle Community Sites
  2. MDLSITE-1309

Got HTTP 500 error when search substring in both 2.0 and 2.1 branch on Simplified Chinese language

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: lang.moodle.org
    • Labels:
      None
    • Rank:
      19839

      Description

      I tried Chinese words and English words, 500 returned.
      I tried selecting 1.9 and 2.0 branch, the result is ok.
      I tried selecting 2.0 and 2.1 branch on English and Traditional Chinese, the result is ok.

      So, it seems that the bug only occurs when:
      1. Simplified Chinese selected
      2. Choose both 2.0 and 2.1 branch

      The bug must hate me only!

        Activity

        David Mudrak added a comment -

        Hi. I just check the log and the problem seems to be in memory limits. If the filter settings would return too many strings, the memory can quickly run out. Please try to make the filter setting more specific.
        I am able to reproduce the error when selecting 2.0 + 2.1 + Simplified Chinese + all standard component. But having for example 2.1 only or one component only works well.
        Unfortunately there is no easy way around - just to learn using the AMOS translator filter so that it returns reasonable amount of data.

        David Mudrak added a comment -

        I tried to increase the server memory limit and the strings are loaded now with no problem.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development