Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: moodle.org
    • Labels:

      Description

      Notice: Undefined index: 0 in /var/www/vhosts/moodle.org/html/course/search.php on line 230

        Gliffy Diagrams

          Attachments

            Activity

            tsala Helen Foster added a comment -

            Anthony, please could you explain how to reproduce this bug.

            samhemelryk Sam Hemelryk added a comment -

            Hi guys,

            It doesn't look like this is strictly a moodle.org bug.
            To reproduce on any site:

            1. Log in as admin
            2. Identify a block that has been added to the site frontpage. It has to be added there and not in the system context, you can't use the navigation/settings blocks so I used something like the calendar block.
            3. Browse to Settings > Plugins > Blocks > Manage blocks
            4. Find the block you chose in the list and click on the number of instances (next to the name) to get a list of all of the courses containing the block.
            5. You should get the notice.

            I reproduced this on my integration site so I'm betting every site is affected.
            Please could someone else test it and move this issue if need be.

            Cheers
            Sam

            poltawski Dan Poltawski added a comment -

            I can't reproduce this issue anymore so closing the isue


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: