Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-1367

Cannot (re)register Moodle 1.9 to moodle.org

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Not a bug
    • Component/s: moodle.org
    • Labels:
      None

      Description

      Elena Ivanova from umn.edu reports via email that she is unable to re-register her colleges 1.9 site to update registration
      after clicking the register button, the page goes into an infinite reload loop - i assume while trying to load/submit data to moodle.org

      Can we reproduce this?

        Gliffy Diagrams

          Attachments

            Activity

            jtomkinson Jordan Tomkinson added a comment -

            I have a feeling this is due to the 2.1 upgrade on moodle.org - its quite possibly broken the pre 2.0 registration scripts
            I am investigating this..

            jtomkinson Jordan Tomkinson added a comment -

            I'm seeing this as the only error relating to registration in the moodle.org apache error_log:

            Debug: error() is a deprecated function, please call print_error() instead of error()\n* line 836 of /lib/deprecatedlib.php: moodle_exception thrown\n* line 251 of /register/index.php: call to error()

            jtomkinson Jordan Tomkinson added a comment -

            Installing Moodle 1.9 to test registration...

            andyjdavis Andrew Davis added a comment -

            In /lib/deprecatedlib.php there is this

            function error($message, $link='') {
                throw new moodle_exception('notlocalisederrormessage', 'error', $link, $message, 'error() is a deprecated function, please call print_error() instead of error()');
            }

            /register/index.php is calling this function instead of print_error(). Note that /register/index.php doesnt seem to exist in my copy of Moodle so its not standard issue core code. Is it something custom that hasn't been updated?

            jtomkinson Jordan Tomkinson added a comment -

            andrew,

            yes its custom, its the moodle.org site registration script

            jtomkinson Jordan Tomkinson added a comment -

            I am unable to reproduce Elena's problem.
            Registration and re-registration works fine from Moodle 1.9.13

            Elena, are you able to provide more technical details regarding the issue?
            Is there anything in the webserver error log when you try to register?

            elenaivanova Elena Ivanova added a comment -

            I have assumed that this is due to the big size of our production installation. I have tested on the "archive" instances from past semesters (same 1.9.8+ (Build: 20100407)), and the smaller instances/semesters are not giving me any trouble.
            I will check with the developers and report back.

            elenaivanova Elena Ivanova added a comment -

            ok, I waited for one hour and got it re-registered.
            We did not see anything in logs, I believe.
            So I think this is just due to the large number of stats...

            Courses: 10865
            Users: 136719
            Role assignments: 315517
            Teachers: 89435
            Posts: 611782
            Questions: 927895
            Resources: 268530

            jtomkinson Jordan Tomkinson added a comment -

            Issue was due to local environment, marking as not a bug.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: