Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: moodle.org
    • Labels:
    • Workaround:
      You could manually break a link when quoting, but this is routine and not largely known, so people usually don't do it.

      Description

      1. Create a forum message with MDL-xxx text. On posting it becomes a link.
      2. Click reply in browser with HTMLEditor, copy and paste text with MDL-xxx link in the new message (quoting). Post this message.
      3. Now you could see something like
      Moodle Tracker" href="http://tracker.moodle.org/browse/MDLSITE-1623">MDLSITE-1623
      (see http://moodle.org/mod/forum/discuss.php?d=192083#p838208 for example)
      instead of link.

      Other similar filters (Moodle doc links etc) may have similar problems.

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Helen Foster added a comment -

            Oleg, thanks for your report. Just noting that the same problem occurs in forum search results.

            Show
            Helen Foster added a comment - Oleg, thanks for your report. Just noting that the same problem occurs in forum search results.
            Hide
            Eloy Lafuente (stronk7) added a comment - - edited

            I've sent this pull request to avoid the filter to break when replacing into tags and/or links anymore:

            https://github.com/moodlehq/moodle-filter_moodlelinks/pull/3

            Let's see how it goes. Ciao

            Show
            Eloy Lafuente (stronk7) added a comment - - edited I've sent this pull request to avoid the filter to break when replacing into tags and/or links anymore: https://github.com/moodlehq/moodle-filter_moodlelinks/pull/3 Let's see how it goes. Ciao
            Hide
            Dan Poltawski added a comment -

            I have deployed Eloy's fix to the clone:
            http://clone.moodle.org/mod/forum/discuss.php?d=192083#p838208

            Once we are happy with the change then I can apply it to production.

            Show
            Dan Poltawski added a comment - I have deployed Eloy's fix to the clone: http://clone.moodle.org/mod/forum/discuss.php?d=192083#p838208 Once we are happy with the change then I can apply it to production.
            Hide
            Helen Foster added a comment -

            Thanks Eloy and Dan. Looks good to me on the clone - link quotations and search results.

            Show
            Helen Foster added a comment - Thanks Eloy and Dan. Looks good to me on the clone - link quotations and search results.
            Hide
            Dan Poltawski added a comment -

            I've deployed this to the production site now.

            Show
            Dan Poltawski added a comment - I've deployed this to the production site now.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development