Moodle Community Sites
  1. Moodle Community Sites
  2. MDLSITE-1663

Implement the "Developers" plugin at moodle.org

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: moodle.org
    • Labels:
      None

      Description

      We need to replace part of the functionality provided by the legacy cvsadmin plugin at moodle.org. The new local plugin /local/dev is supposed to:

      • gather activity traces of git commits in the main moodle.git repository
      • gather activity traces of comments and transitions in JIRA
      • aggregate traces per moodle.org user
      • produce a list of Moodle developers and simple amount of their contribution (totally and per release)

        Issue Links

          Activity

          David Mudrak created issue -
          David Mudrak made changes -
          Field Original Value New Value
          Assignee Helen Foster [ tsala ] David Mudrak [ mudrd8mz ]
          David Mudrak made changes -
          Link This issue is blocked by MDL-31666 [ MDL-31666 ]
          David Mudrak added a comment -

          This can't be deployed until MDL-31666 is fixed in the main moodle.git

          David Mudrak added a comment -

          The overall architecture of the plugin is described at http://docs.moodle.org/dev/Developer_credits_processor

          David Mudrak made changes -
          Link This issue will help resolve MDLSITE-1724 [ MDLSITE-1724 ]
          Andrew Davis added a comment -

          Hi David. Just have some feedback.

          As a not logged in user I could go to http://moodle.org/dev/contributions.php, click on my list of commits and see my email address in the commit list. I've since modified my moodle.org profile to use my moodle.com email address instead of my personal email address so this is less of an issue but it still seemed odd. Maybe this information is already public and I'm being paranoid

          Is there a reason there are no commits listed since late December for me? http://moodle.org/dev/gitcommits.php?version=x.x.x&userid=1023607&merges=0
          I had a look at a few other people (Aparup and Rossie) and they don't list any commits since around the same time.

          David Mudrak added a comment -

          Hi Andrew. Thanks for the feedback.

          You are right. For what I thought was a good reason, the commits were displayed with the name and email from the profile. This was intended to make old CVS and early Git commits (when folks were learning it and used to forgot to config their name and email) nicer. I did not realize that email is actually the protected info. Also, as Dan Poltawski pointed out, it is sometimes significant to keep the original name and email as recorded in the commit as it can suggest the user's employer, for example. So I reverted the behaviour and now the commits are displayed as they are - with recorded names and emails (and those are really public). Thanks for raising this.

          With regards to your recent activity, the contributions are grouped by release version (tag in Git). Recent commits from MOODLE_xx_STABLE and the master branch are not part of any release yet, hence they do not appear in the report. Once we release them (we do it every two months now), they will be summarized and published automatically. There is a solution on how even recent commits could be reported in the future, should there be a big demand for it.

          Thanks again.

          David Mudrak added a comment -

          Adding docs_required tag

          David Mudrak made changes -
          Labels docs_required
          Helen Foster added a comment -

          Moodle Docs for this page link for moodle.org/dev now redirects to http://docs.moodle.org/dev/Credits

          To do: Update http://docs.moodle.org/dev/Credits and include a bit of info on how to interpret moodle.org/dev figures.

          Mary Cooch made changes -
          Labels docs_required dev_docs_required
          Mary Cooch added a comment -

          Just changed this to dev docs required instead of docs required

          David Mudrak made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          David Mudrak added a comment -

          This has been in production for a while, closing now.

          David Mudrak made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Martin Dougiamas made changes -
          Workflow jira [ 103076 ] SITES Full Workflow [ 127424 ]
          David Mudrak made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          David Mudrak made changes -
          Labels dev_docs_required
          David Mudrak made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          David Mudrak made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development