Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: moodle.org
    • Labels:
      None
    • Rank:
      43449
    1. BBCMobileExamples.png
      21 kB
    2. BBCSmartphoneMenus.png
      119 kB
    3. GuardianMobileColourCoding.png
      108 kB
    4. GuardianSmartphoneview.png
      42 kB

      Issue Links

        Activity

        Helen Foster added a comment -

        Latest idea is to organise top menus by site and help avoid confusion about which site you are on by colouring them differently.

        https://docs.google.com/spreadsheet/ccc?key=0AmamVlPpCnn4dHpSRTByb2pJWHljUzMxYlE5dDg1d3c&hl=en_GB#gid=1

        Helen Foster added a comment -

        Notes from moodle.org meeting today:

        • Good plan to have top menu listing sites - moodle.org, docs, downloads, demo, tracker etc as on spreadsheet https://docs.google.com/spreadsheet/ccc?key=0AmamVlPpCnn4dHpSRTByb2pJWHljUzMxYlE5dDg1d3c&hl=en_GB#gid=1 (inspiration from http://bbc.co.uk/)
        • Under the top menu should be the site name, together with a strap line (short description of the site)
        • Site menu stuff should be under the site name
        • The different sites should be clearly identifiable, though having them all in different colours is not necessary (so ignore the colours on the spreadsheet - Helen is no designer!)
        • Search boxes should be positioned top right, as shown in the spreadsheet
        • Focus on moodle.org redesign first, other sites can be done later
        • Simple top menu listing sites can be hard-coded - no nightmares having to maintain it!

        I'm adding all meeting attendees as watchers to this issue for you to add further notes of anything important which I missed.

        Helen Foster added a comment -

        Amending description according to agreement reached in 09/01/13 meeting.

        Helen Foster added a comment -

        Reopening, since from looking at mock-ups for MDLSITE-1890, it seems we need to consider narrow screen usage.

        Mary Cooch added a comment -

        I am struggling with understanding how to accommodate narrow screen usage so I took a few screenshots of the BBC and the Guardian website mobile versions - both the mobile version as seen on my desktop and the much collapsed version as seen on my Android smartphone. I am attaching some images and would be grateful if someone could explain the issues. Both mobile sites (I have ignored the desktop versions of these websites) show the related sites (eg BBC sport/News) and the related sites are colour-coded to avoid confusion. However, both sites keep the main menu the same at the top in whichever related site you are in. As your screen gets narrower, you see fewer of the related sites in the top menu but they appear in a dropdown. Pages within each related site (specific sports for example, or news from different countries) appear in a tab or again in a selectable drop down menu according to the size of the screen. Screenshots:

        1: BBC Mobile site top menu as seen on my desktop - colour coded related sites but top menu the same -= more or fewer options seen according to the screen size
        2: Smart phone views of BBC Site. The "Menu" link provides a link and consistency between all related sites.
        3:Guardian mobile website as seen on a desktop. Again, top menu shows all related sites with each site displaying in a different colour to avoid confusion
        4: Smart phone view of Guardian website.

        Barbara Ramiro added a comment - - edited

        Hi Mary, the issue is having 2 layers of navigation bars on widescreen (1 for all the sites and 1 for a particular site) It looks a bit too much so my idea is to de-clutter the interface by having all the sites on a dropdown menu and then only the navigation for a particular site is shown on the top navigation. Please read my comment on MDLSITE-1890 dated 29/May/13 1:22 PM and please see screenshots dated 29/May/13 1:55 PM and 27/May/13 4:35 PM. Cheers

        Helen Foster added a comment -

        Re-resolving, as the following top menu was agreed in the 31/05/13 sites meeting:

        moodle.org documentation downloads demo tracker development translation moodle.net

        (Still to be decided: whether to capitalize the site names or not.)

        Aparup Banerjee added a comment -

        I'm trying to use the spreadsheet to build menus. Is there anywhere that the urls are mentioned too?

        Aparup Banerjee added a comment -

        I've got moodle.org menu urls so far as:
        Moodle.org|http://moodle.org
        -About
        --Features tour|http://docs.moodle.org/25/en/Features_tour
        --Demonstration sites|http://demo.moodle.net
        --History
        --Moodle statistics|https://moodle.org/stats/
        --Registered sites|https://moodle.org/sites/
        --Moodle credits|http://docs.moodle.org/dev/Credits
        -News|https://moodle.org/news/
        --Announcements|https://moodle.org/news/
        --Security news|https://moodle.org/security/
        --Moodle Buzz|http://moodle.org/mod/data/view.php?d=19
        --Planet Moodle|http://planet.moodle.org/
        -Support
        --Courses|https://moodle.org/course/
        --Moodle Partners|http://moodle.com/partners/
        --Books|https://moodle.org/mod/data/view.php?id=7246
        -Community
        --Calendar|https://moodle.org/calendar/view.php
        --Policies
        --Moodle jobs|https://moodle.org/mod/data/view.php?id=7232
        --Moodle shop|http://www.cafepress.com/moodle/
        --Get involved!|http:/moodle.org/forums
        -My courses|https://moodle.org/my/

        please amend as necessary.

        Mary Cooch added a comment -

        I think we are using http://docs.moodle.org/25/en/Features for the top menu according to this MDLSITE-2076 (just to check with Helen)

        Helen Foster added a comment -

        I've started listing submenu links in https://docs.google.com/spreadsheet/ccc?key=0AmamVlPpCnn4dHpSRTByb2pJWHljUzMxYlE5dDg1d3c&hl=en_GB#gid=2 and have created MDLSITE-2303 for comments and agreeing on the moodle.org submenu.

        As Mary mentions, the content for moodle.org/features will be taken from http://docs.moodle.org/en/Features (We won't link to the docs, as all moodle.org submenu items should be moodle.org pages.)


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development