Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-1937

make requiring version.php and ->version strict requirement for all plugins > 2.4. (so Themes and course formats should require it)

    XMLWordPrintable

    Details

      Description

      For awhile now this has been a requirement but not for all 2.x plugins: see http://docs.moodle.org/dev/Plugin_validation#Exceptions

      so atm Themes and course formats don't require it in 2.x

      should we require version.php for all plugins (only in 2.4?) This will aid in MDL-35238 where we're trying to automate installation of plugins from plugins DB.

      ps: editing a pluginversion(.php) allows version number editing apparently due to this flexibility requirement.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: