Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: docs.moodle.org
    • Labels:
      None

      Description

      I've seen yesterday that i wasn't able anymore to connect to any MoodleDocs (french, dev, english versions).
      I had no problem some days ago...

      Talked about that in this discussion :
      https://moodle.org/mod/forum/discuss.php?d=228275

        Gliffy Diagrams

          Activity

          Mary Cooch added a comment -

          Yes - I have found that for docs where I am already logged in, there is no problem but for other docs such as the French docs where I was logged out, I get the same message( error - incorrect password entered)

          Eloy Lafuente (stronk7) added a comment -

          It should be working right now.

          The cause was the new, more robust, hashing coming with Moodle 2.5 (MDL-35332) and running @ moodle.org since yesterday. We missed to update the Moodle Docs authentication extension that uses those new moodle.org hashes.

          Now the extension tries the new hashing and fallbacks to older ones, so anybody should be able to connect, no matter if has logged-in to moodle.org recently (new hashes) or no (old hashes).

          Any feedback will be welcome, TIA, ciao

          Séverin Terrier added a comment -

          Thanks Eloy : it works OK now !
          This bug can be marked has resolved/closed.

          Mary Cooch added a comment -

          Yes it does! And Séverin beat me to it

          Eloy Lafuente (stronk7) added a comment -

          I'll keep it open because still requires some integration/git magic to happen to have it 100% done, thanks!

          David Mudrak added a comment -

          For the record (for myself mainly as I'm recovering REL1_17_private now):

          message sent by Eloy for hq-admins

          Hi Dan,
          I've created 2 pull requests with the changes for the current 1_17 and future 1_20 branches:
          REL1_17_private: https://github.com/moodlehq/mediawiki/pull/4
          REL1_20_private: https://github.com/moodlehq/mediawiki/pull/5
          Then, it's important to know that I've installed the fixed auth extension !!! BY HAND !!! because I was not confident/sure about the current status of the 1800_deploy branch (given you comments last week about history borked and so on).
          So, once the pull requests are accepted, it's needed to merge the 17_private change onto 1800_deploy and, surely, deploy it properly. For your knowledge...
          Ciao

          The patch fde5a6a588d1ff6e060536a2b3c633268c0926dc was added into REL1_17_private but it has not been merged into MDLSITE-1800_deploy.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development