Moodle Community Sites
  1. Moodle Community Sites
  2. MDLSITE-234

Authenticated user role missing from demo.moodle.org

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Component/s: demo.moodle.net
    • Labels:
      None
    • Rank:
      25151

      Description

      When logged in as admin on demo.moodle.org, the Authenticated user role is not anywhere visible. For example, I cannot find it anywhere in Site administration -> Users -> Permissions or Site administration -> Front page -> Front page roles. When logged to my own site, also running 1.8.2+, the Authenticated user role is visible.

      If this is by design, would it be possible to enumerate the other ways in which the demo site code has been changed? I do a lot of testing there, particularly with roles.

        Activity

        Martin Dougiamas added a comment -

        It got added later, probably after the roles upgrade on the demo site.

        It's about time the demo site had a refresh actually ... I'll drop it now and reinstall from scratch.

        Martin Dougiamas added a comment -

        Site refreshed. If it was a real site I could have just recreated the new role manually, but, this was quicker.

        John Isner added a comment -

        Since the demo site is supposed to be the latest stable release (it says so on the front page), I often test things there. If the site turns out to be unreliable, what use is it? I just got shot down in a discussion over a feature I swore wasn't working because the demo site said so.

        I assumed the demo site was kept in sync with the latest stable release using cron and cvs update. If not, what is the process, and what will the process be going forward?

        According to alexa.com, 4% of all moodle.org traffic goes to the demo site. I assume people go there for the same reason I do. If it's not a "real site," shouldn't they be warned?

        John Isner added a comment -

        Why not put the demo site into maintenance mode once every 24h and do a cvs update? Then the site could be advertised as the latest stable release with a 24 hour guarantee.

        Martin Dougiamas added a comment -

        John, it's a demo site I provide for convenience. It's not meant to be a reference implementation of the code.

        The current latest source code is always available via CVS if you want the very latest, plus there are daily builds on the download page.

        Automatically upgrading Moodle as you describe is not easy and probably not advisable if things go wrong. It will be easier when we have command line upgrading (Google SOC student is working on it) but even then possibly a problem every now and then. I'll look into it though.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development