Moodle Community Sites
  1. Moodle Community Sites
  2. MDLSITE-235

demo.moodle.org should always reflect the latest stable release

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a bug
    • Component/s: demo.moodle.net
    • Labels:
      None
    • Rank:
      25152

      Description

      According to alexa.com, 4% of all moodle.org traffic goes to the demo site. I assume that others go there for the same reason I do: to try out new features.

      I recently got burned by a serious discrepancy between the demo site and the latest stable release (see MDLSITE-234). The problem was fixed quickly, but it left me wondering about the process by which demo.moodle.org is maintained, and what guarantees users have when using this site.

      Suggestion: set up cron to put demo.moodle.org into maintenance mode and do a cvs update to the latest stable release at least once every 24h. Then advertise the site as the latest stable release with a 24h guarantee.

      If this can't be done, the front page should warn users that the release may be different from latest stable release.

        Issue Links

          Activity

          Martin Dougiamas added a comment -

          (copy of a comment from MDLSITE-234 because it's more appropriate here)

          John, it's a demo site I provide for convenience. It's not meant to be a reference implementation of the code.

          The current latest source code is always available via CVS if you want the very latest, plus there are daily builds on the download page.

          Automatically upgrading Moodle as you describe is not easy and probably not advisable if things go wrong. It will be easier when we have command line upgrading (Google SOC student is working on it) but even then possibly a problem every now and then. I'll look into it though.

          Séverin Terrier added a comment -

          I think it would be good/usefull to have demo.moodle.org updated more often, to better reflect latest version.

          Certainly not each day, perhaps not each week, but at least after each new release, and/or once a month. Updating langages also would be a good idea.

          Taking about now, demo version is Moodle 2.0 from 2010/12/06, it should be at least 2.0.1...

          Jordan Tomkinson added a comment -

          cleaning up old issues, this is no longer relevant.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development