Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-2845

Anchor link hidden below #moodlesitestopnavbar after following it

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Component/s: docs.moodle.org
    • Labels:
      None

      Description

      Steps to reproduce:

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              dmonllao David Monllaó added a comment -

              Adding Aparup and Barbara as watchers.

              nebgor Aparup Banerjee added a comment -

              thanks, this will need a quick hack i suppose to docs code as the body needs to be appended with a margin-top: 60px;
              (it can't be added to the sidebar itself).
              David Mudrák might be familiar with it here.

              barbararamiro Barbara Ramiro added a comment -

              It happens to forum and glossary as well

              mudrd8mz David Mudrák added a comment -

              Yes, it's known issue. We fixed it only for forums at moodle.org, such as https://next.moodle.org/news/#p1092029

              fox Séverin Terrier added a comment -

              Yes, it's not practical for docs. I've just open https://moodle.org/mod/forum/discuss.php?d=256114 about that, before seeing this tracker item...

              mudrd8mz David Mudrák added a comment -

              This should be fixed now.

              For the record, just in case Barbara Ramiro is interested, the following bit in the docs skin LESS file did the trick:

              h1, h2, h3, h4, h5, h6 {
                     > span[id].mw-headline {
                             padding-top: 60px;
                             margin-top: -60px;
                     }
              }
              

              mudrd8mz David Mudrák added a comment -

              I was pinged by Matthew Spurrier that Michael de Raadt is experiencing some regression in links behaviour caused by this change. Michael, can you please report details here? I am not able to reproduce the buggy behaviour your described to Matt. Thanks in advance.

              mspurrier Matthew Spurrier added a comment -

              Michael just showed me how to replicate the issue.

              Shrink the screen on the left hand side, there is a 60px invisible block that covers up the link when the screen is shrunk.

              Matt

              mudrd8mz David Mudrák added a comment -

              OK I think I see it now. We will have to review this hack - we use it at moodle.org forums too (for those #p12345 links).

              mudrd8mz David Mudrák added a comment -

              Reopening.

              poltawski Dan Poltawski added a comment -

              Some reports of the clicking bug on this forum thread: https://moodle.org/mod/forum/discuss.php?d=256833

              mudrd8mz David Mudrák added a comment -

              Thanks for the links Aparup. I have adopted a solution

              h1, h2, h3, h4, h5, h6 {
                      > span[id].mw-headline:before {
                              display: block;
                              content: "";
                              height: 60px;
                              margin: -60px 0 0;
                      }
                      > .editsection {
                              margin-top: 60px;
                      }
              }
              

              and it seems to work for me.

              mudrd8mz David Mudrák added a comment -

              Resolving this. Ideally the new solution should be tested in as many browsers as possible. It seems to work for me in FF and Chrome (Linux).

              marycooch Mary Cooch added a comment -

              I just tried http://docs.moodle.org/26/en/Question_bank which was an example of where it was broken. I am on Windows 8 using Chrome, Firefox and Internet Explorer and it all works fine for me now; very relieved.

              rezeau Joseph Rézeau added a comment -

              Works for me too on Windows 7, in those 3 browsers: Firefox, Chrome and MSIE.
              Thanks for the fix!
              Joseph


                People

                • Votes:
                  3 Vote for this issue
                  Watchers:
                  10 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: