Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-4887

Modal's have wrong z-index

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: moodle.org
    • Labels:
      None
    • Workaround:
      Hide
      Add:

      {code}
      style="z-index: 4050;"
      {code}

      to the selector containing the 'modal' class.
      Show
      Add: {code} style="z-index: 4050;" {code} to the selector containing the 'modal' class.

      Description

      On the themes forum (https://moodle.org/mod/forum/view.php?id=46) a modal is used for the the 'forum rules' via a button. This is the standard Bootstrap modal mark-up. However the site theme has the CSS:

      .modal-backdrop {
          z-index: 4049;
          background-color: #aaa;
          opacity: .4;
      }
      

      which replaces the standard '@zindexModalBackdrop' variable value of '1040' so that the Moodle navigation bar is hidden by the backdrop. But the value of '@zindexModal' being 1050 has not been altered for the 'modal' class, thus the modal itself appears hidden too, so either '@zindexModal' needs to be 4050 or add the CSS:

      .modal {
          z-index: 4050;
      }
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            gb2048 Gareth J Barnard
            Participants:
            Component watchers:
            Helen Foster
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: