MDL-57432 some new requirements are coming for 3.4 and up.
- php 7.0 being min version.
- moodle 3.4 requiring 3.0 or up for upgrading.
- intl extension required
This is about to review and reorganize all CI servers (public and 2 laptops) to fullfill the above while covering as many combinations of php/db as possible.
Versions spread as follows:
- public ci server (integration.moodle.org): everything is run using php 7.0 (post-chains, prechecker...)
- laptop 1 (ci.stronk7.com): always use the oldest php version supported (5.4 for Moodle 3.1, 5.6 for Moodle 3.2 and 3.3 and 7.0 for 3.4 and up).
- laptop2 (ci7.stronk7.com:81): always use the newest version supported (7.0 for Moodle 3.1, 7.1 for Moodle 3.2 and up).