Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-5390

Privacy API version requirement

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Do
    • Component/s: moodle.org/plugins
    • Labels:
      None

      Description

      When adding a new version of a plugin via 'https://moodle.org/plugins/addversion.php' you stipulate the major version of Moodle supported.  However as there is a new Privacy API - MDL-59286 - then there is a 'mid-version' requirement.  Thus any developer implementing the API would want the changes to only appear for Moodle sites running Moodle with the Privacy API - thus for 3.4 that would be 3.4.2.  Then older sites won't think they can update to a new version of the plugin that then may fail update requirements.  Therefore there should be the option and upgrade constraint to specify 3.4.2 instead of 3.4 as an example.

      I believe that the Moodle version field helps with this 'there is a new version for your Moodle' functionality?

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: