Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-6226

Update the affected and fix branches Jira plugin to support > .9 versions

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Low
    • Resolution: Fixed
    • tracker.moodle.org
    • None

    Description

      We have a custom plugin in Jira (see MDLSITE-706) that, based on the affected and fix versions for an issue, calculates the name of the moodle branches affected and fixed.

      3.1 => MOODLE_31_STABLE
      4.0 => MOODLE_40_STABLE
      ...
      

      Then, based in that information, there are a few filters and searches using them.

      The plugin does not support versions beyond .9 so versions like 3.10 don't get the MOODLE_310_STABLE calculated.

      This issue is about:

      1) Compiling the fields with a newer Atlassian's SDK.
      2) Fix the logic to support > .9 versions.

      Attachments

        1. 3digit_branches_calculated_ok.png
          89 kB
          Eloy Lafuente (stronk7)
        2. after.png
          210 kB
          Mark Paget
        3. before.png
          234 kB
          Mark Paget
        4. claculated_branches_next.png
          103 kB
          Eloy Lafuente (stronk7)
        5. evidence of upgrade.png
          38 kB
          Mark Paget
        6. evidence of upgrade2.png
          96 kB
          Mark Paget
        7. Screen Shot 2020-08-20 at 9.02.36 pm.png
          92 kB
          Mark Paget

        Issue Links

          Activity

            People

              markp Mark Paget
              stronk7 Eloy Lafuente (stronk7)
              Eloy Lafuente (stronk7) Eloy Lafuente (stronk7)
              Adrian Greeve, Jun Pataleta, Marina Glancy, Eloy Lafuente (stronk7)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: