Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-6382

Verify testers VM supports PHP 7.3 and (soon) PHP 8. And other small requirements.

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Low
    • Resolution: Fixed
    • Integration
    • None

    Description

      This is one of the points to check after bumping requirements for Moodle 3.11 and up (MDL-69308).

      The minimum PHP version supported will be 7.3 and, also, PHP 8 support is expected to come soon.

      So this issue is about to ensure that the external testing environment supports those PHP versions.

      Also raised / changed are these requirements:

      • SQL*Server 2017 and up (our current docker image already supports that).
      • The sodium extension must be installed (it comes that way by default).

      Ciao

      Attachments

        Activity

          People

            jpataleta Jun Pataleta
            stronk7 Eloy Lafuente (stronk7)
            Eloy Lafuente (stronk7)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: