Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-6387

Problem with the auto install feature

    XMLWordPrintable

Details

    Description

      Hello,

      I used the installation from Moodle site feature in Moodle to install several plugins. For the most of them everything went well. But i get an outdated version for a few especially one : subcourse which gave me the 5.0.1 version when I picked the 9.0.1 and ran "Install now".

      The version 5.0.1 of subcourse make use of deprecated features that prevent it to work properly in Moodle 3.10+.

      A second try gave me the same result.

      To solve this problem, I downloaded the zip file using the proper button in Moodle plugins List and installed it in my instance of Moodle. I got the right version of the plugins and everything work fine now.

      After a look at "My sites" i saw that my Moodle instance was registered as a version 3.1 instead of the 3.10. I corrected the version number via the edition page. Now, I've no more "Install Now" possibilities in the Moodle plugins List.

      It's quite disappointing : either an outdated version of a plugin may be installed, or i can't use the Install from Moodle Site feature.

      Anyway, thank you very much for this so precious software

      Regards

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              lfallot LaurentFALLOT
              David Mudrák (@mudrd8mz)
              Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated: