Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-6427

download checker getting wrong version for plugins that do not have a 3.10 release.

    XMLWordPrintable

    Details

      Description

      Something seems wrong with the download checker when looking for plugin updates for Moodle 3.10

      reported on:

      https://moodle.org/plugins/report_coursesize

      After upgrade to 3.10, the plugin manager keeps reporting report_coursesize as outdated. But the version suggested is lower than that installed:

      • installed plugin version: 2019052800
      • version suggested: 2016051600 (There is a new version 2016051600 available!)

      2016051600 happens to be an old release for 3.1.

      If you hit the following url you can see this reproduced:
      https://download.moodle.org/api/1.3/updates.php?format=json&version=2020061502&branch=3.10&plugins=report_coursesize

      If you swap out the "3.10" branch for "3.9"

      https://download.moodle.org/api/1.3/updates.php?format=json&version=2020061502&branch=3.9&plugins=report_coursesize

      You get no response for the report_coursesize which is what I would expect because we haven't published a version for 3.9

        Attachments

          Activity

            People

            Assignee:
            mudrd8mz David Mudrák (@mudrd8mz)
            Reporter:
            danmarsden Dan Marsden
            Participants:
            Component watchers:
            Eloy Lafuente (stronk7)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: