Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-685

In the moodle.org forums, indenting does not work

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: moodle.org
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Make a forum post.
      2. In the HTML editor, use the indent button to indent a paragraph
      3. Save.

      Actual result:

      The indent is lost.

      Expected result:

      Well Duh!

      ------

      Looking, It seems that the HTML editor adds a <div style="margin-left: 40px;"> to do the indent, and Moodle then strips out the style attribute.

      Also, if you try, as a work-round, using a more semantic <blockquote> tag, it seems that the Moodle 2.0 stylesheet sets that to 0 indent, which is stupid.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              timhunt Tim Hunt created issue -
              timhunt Tim Hunt added a comment -

              The Moodle2 theme also breaks <dl> formatting. If designers insist on using a browser styles reset script then they must ensure that they put back sensible formatting for all HTML elements.

              korpelainen Mauno Korpelainen added a comment -

              I agree - it's the same problem as

              http://tracker.moodle.org/browse/MDLSITE-681 (fixed already)

              http://tracker.moodle.org/browse/MDLSITE-553 and http://tracker.moodle.org/browse/MDLSITE-561 (font tags can be used in editor but formatting is lost)

              I could add to this list valid xhtml elements <big> and <small> (reset.css resets also these) but I have never seen them used here (moodle.org) because people usually change font size instead of using xxxx <big>yyy</big> xxx <small>zzz</small>

              tsala Helen Foster added a comment -

              Tim, thanks for your report, and Mauno, thanks for your comments.

              Reassigning to our moodle2 theme tweaker...

              tsala Helen Foster made changes -
              Field Original Value New Value
              Assignee Helen Foster [ tsala ] Martin Dougiamas [ dougiamas ]
              korpelainen Mauno Korpelainen added a comment -

              One more add - of course that reset.css breaks also other lists like

              <ol>
              <li>Coffee</li>
              <li>Milk</li>
              </ol>

              or

              <ul>
              <li>Coffee</li>
              <li>Milk</li>
              </ul>

              So

              dl, dt, dd, ol, ul, li,
              + big and small

              should probably be also totally removed from those first css tags mentioned in http://tracker.moodle.org/browse/MDLSITE-681 unless Urs gives them new css elsewhere in css. If no css is given those tags should use browser default css so resetting styles to "normal text" is not reasonable.

              korpelainen Mauno Korpelainen added a comment -

              ...and I forgot that

              blockquote

              that Tim mentioned.

              korpelainen Mauno Korpelainen added a comment -

              ...and one more comment

              I just checked a forum post and those ol, ul and li tags are defined in css of moodle.org elsewhere - only dl, dt, dd, blockquote, big and small seem to be undefined.

              korpelainen Mauno Korpelainen added a comment -

              Finally <big> and <small> are not even in $ALLOWED_TAGS in weblib.php so moodle would cut them anyway if somebody tried to use them.

              tsala Helen Foster made changes -
              Link This issue is duplicated by MDLSITE-814 [ MDLSITE-814 ]
              tsala Helen Foster added a comment -

              Increasing the priority of this issue in the hope that it can be fixed soon to prevent further annoyance (see linked issue).

              tsala Helen Foster made changes -
              Priority Minor [ 4 ] Major [ 3 ]
              dougiamas Martin Dougiamas made changes -
              Workflow jira [ 31148 ] SITES Full Workflow [ 125269 ]
              tsala Helen Foster made changes -
              Workflow SITES Full Workflow [ 125269 ] SITES workflow plus [ 134964 ]
              poltawski Dan Poltawski added a comment -

              Hi Tim,

              I think the indenting works now, so I think this old issue could be closed - what do you think?

              timhunt Tim Hunt added a comment -

              I agree. Closing.

              timhunt Tim Hunt made changes -
              Status Open [ 1 ] Closed [ 6 ]
              Assignee Martin Dougiamas [ dougiamas ] Tim Hunt [ timhunt ]
              Resolution Cannot Reproduce [ 5 ]

                People

                • Votes:
                  3 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: