Details
-
Improvement
-
Status: Open
-
Low
-
Resolution: Unresolved
-
None
Description
The Moodle Coding Style (MCS) states:
Function names should be simple English lowercase words, and start with the[ Frankenstyle|https://moodledev.io/general/development/policies/codingstyle/frankenstyle] prefix and plugin name to avoid conflicts between plugins. Words should be separated by underscores.
PSR-12 states:
Method names MUST be declared in camelCase().
Required decision: Keep the MCS naming convention or adopt the PSR-12 recommendation?
Possibly a first pass would be to keep the Frankenstyle prefix as it’s required in many places?
MCS: https://moodledev.io/general/development/policies/codingstyle#functions-and-methods