Uploaded image for project: 'Moodle Community Sites'
  1. Moodle Community Sites
  2. MDLSITE-7570

Policy suggestion: Ad-hoc task get_name methods should be required to put key identifiers in the name


    • Icon: Improvement Improvement
    • Resolution: Unresolved
    • Icon: Low Low
    • Coding style

      I will explain this by way of an example:

      If I want to know why (one instance of) quiz_statistics\task\recalculate is slow, I go to the task logs and I see:

      This is not very helpful.

      In fact, this task always runs for a particular quiz, and ->customdata contains $quizid. Since get_name is an instance method, there is no issue with making get_name return "Recalculate question statistics for quiz id 1234", and I imagine most other tasks are similar.

      This would be such a big win for admins, that I don't just want to fix this one task. I want to make it a policy. (Because current practice in core is to have un-helpful names for all ad-hoc tasks.)

            Unassigned Unassigned
            timhunt Tim Hunt
            1 Vote for this issue
            4 Start watching this issue


                Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.