Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: git.moodle.org
    • Labels:
      None

      Description

      the link to get a snapshot of files beside each commit seems to be generating corrupt files - catalyst gitweb seems fine.

        Gliffy Diagrams

          Attachments

            Activity

            mudrd8mz David Mudrák added a comment -

            Confirmed, thanks for spotting this. I just realized the snapshot is just gziped twice. I will look at the script but it looks like they are calling "tar czf" and gzip the result manually again.

            At git.moodle.cz, I use ViewGit instead of gitweb and I have no problems there, too. What gitweb version do you use in catalyst Dan?

            danmarsden Dan Marsden added a comment -

            Hi David - it was the same version as used on git.moodle.org last time I looked - (I generated and tested the git.moodle.org theme on our repo before Francois passed it over to Jordan) - not sure if either has been changed since them.

            mudrd8mz David Mudrák added a comment -

            OK. I am not able to unpack the downloaded snapshot via 'tar xzf'. BUT I am able to do so by calling gunzip first and then unpack the plain tar with 'tar xf'. Weird.

            Anyway, I am unassigning this from myself. If somebody has free time to explore this more, please do so.

            poltawski Dan Poltawski added a comment -

            Looks like this has been fixed somewhere along the way as it now seems to be working fine for me..


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: