Moodle Community Sites
  1. Moodle Community Sites
  2. MDLSITE-978

Some strings don't appear in AMOS translator interface

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Component/s: lang.moodle.org
    • Labels:
      None
    • Rank:
      25754

      Description

      Some strings, eg. 'upgradestart' in core admin.php file, don't appear in AMOS translator interface.

        Activity

        David Mudrak added a comment -

        Grrr good spot Nicolas!

        AMOS did not register any change in English language pack from several last days. It is apparently caused by a regression in Forum module. AMOS uses the Forum for notification of changes and something went wrong there. I have temporarily disabled the notification feature and the missing strings are now there in AMOS. I am going to explore what is going on.

        Thanks once more again.

        David Mudrak added a comment -

        Hmm, weird. After the server update, it started to work again. There is no apparent reason why the forum integration should not work. I have re-enabled the notifications into the forum and we will see.

        David Mudrak added a comment -

        I am going to wait if the problem raises again.

        David Mudrak added a comment -

        This happened again. No English string modifications were regsitered by AMOS since 18 December 2010

        David Mudrak added a comment -

        Should be finally fixed now. There was a malicious bug in stripping the notification forum post subject to 256 characters. The bug caused that in some rare cases, the subject string was actually longer than 256 characters which led to constant dml_write_exception and since then, no English strings could be processed.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development