Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-1796

Update Node.js to 6.x

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.3.0
    • Component/s: Others
    • Labels:
    • Testing Instructions:
      Hide
      1. Install node 6.9.1 and update npm (I have 4.0.1 now).
      2. Run npm install in the project folder. Check that the dependencies are updated.
      3. Do some change in a JS file and run gulp. Check that no error is shown (only the graceful-fs warning) and that the change is applied to the build file.
      4. Check that you can install the app in Android and iOS.
      Show
      Install node 6.9.1 and update npm (I have 4.0.1 now). Run npm install in the project folder. Check that the dependencies are updated. Do some change in a JS file and run gulp . Check that no error is shown (only the graceful-fs warning) and that the change is applied to the build file. Check that you can install the app in Android and iOS.
    • Affected Branches:
      MOODLE_32_STABLE
    • Fixed Branches:
      MOODLE_33_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Sprint:
      Moodle Mobile 3.3.0

      Description

      The project is currently using 0.12 version, while version 6.x is the latest recommended LTS version. Moodle is thus lagging behind Node.js.

      Is there a reason to not upgrade? Otherwise we have a team here that could do this.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                3 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  26/May/17