Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-1843

npm install fails with Appium 1.6.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 3.1.3
    • Fix Version/s: None
    • Component/s: Others
    • Labels:

      Description

      To reproduce: Do "npm install" from a clean clone of the master branch.

      It does work with 1.5.3, but not with 1.6.0, so a breaking change must have happened.

      The issue has been reported in the appium repo: https://github.com/appium/appium/issues/6992
      The appium readme states that node version 4 or greater is required, so the only solution seems to be locking the version to less than 1.6.0 or upgrading node.

      MOBILE-1796 will solve this issue.

      Otherwise, this patch will work around it:

      From 6b832c761da36ecd33548c9b8e0bffc42a21230d Mon Sep 17 00:00:00 2001
      From: Magnus Bjerke Vik <mbvett@gmail.com>
      Date: Thu, 27 Oct 2016 17:01:37 +0200
      Subject: [PATCH] Force appium version to be below 1.6 to fix npm install issue
       
      ---
       package.json | 2 +-
       1 file changed, 1 insertion(+), 1 deletion(-)
       
      diff --git a/package.json b/package.json
      index 01890db..95a995e 100644
      --- a/package.json
      +++ b/package.json
      @@ -10,7 +10,7 @@
           "gulp-rename": "^1.2.0"
         },
         "devDependencies": {
      -    "appium": "^1.4.11",
      +    "appium": "^1.4.11 <1.6.0",
           "bower": "^1.3.3",
           "gulp-clip-empty-files": "^0.1.1",
           "gulp-concat-util": "^0.5.2",
      -- 
      2.7.4
       
      
      

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                4 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: