Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-2375

Problem in Desktop App if LDAP auth is misconfigured.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Do
    • Affects Version/s: 3.4.1
    • Fix Version/s: None
    • Component/s: Moodle Desktop
    • Labels:
    • Affected Branches:
      MOODLE_34_STABLE

      Description

      We found the problem that if there is a misconfiguration in LDAP auth method its not possible to add the instance to the App by adding the URL. In consequence also manual authenticated users can't login.

      Juan found this error message:

      {"error":"LDAP-module cannot connect to any servers: Server: 'ldap:\/\/ xxx.xxx.xxx

      ', Connection: 'Resource id #19', Bind result: ''\n","errorcode":"auth_ldap_noconnect_all","stacktrace":null,"debuginfo":null,"reproductionlink":null}

       

      After disabling  LDAP auth the App accesss worked correct.

      The concrete reason is that there is a misconfiguration on the site. But its intersting that users with Android or iOS devices could use the App.

      I was confused that the auth method is checked when the user adds the site URL.

      Moodle 3.4.1, actual version of App

      Thanks for your helpfull support, Juan

       

        Attachments

          Activity

            People

            Assignee:
            jleyva Juan Leyva
            Reporter:
            ralfh Ralf Hilgenstock
            Participants:
            Component watchers:
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: