Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-2882

Restore browser SSO in Mac apps

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.6.0
    • Fix Version/s: 3.7.0
    • Component/s: Moodle Desktop
    • Labels:
    • Testing Instructions:
      Hide
      1. In web as admin, configure a site to use SSO "via a browser window" (not embedded).
      2. In the Mac app, try to add that site. Check that the system browser is opened (Safari, Chrome, ...).
      3. Authenticate in the browser. Check that the app is opened and you're authenticated.
      Show
      In web as admin, configure a site to use SSO "via a browser window" (not embedded). In the Mac app, try to add that site. Check that the system browser is opened (Safari, Chrome, ...). Authenticate in the browser. Check that the app is opened and you're authenticated.
    • Affected Branches:
      MOODLE_36_STABLE
    • Fixed Branches:
      MOODLE_37_STABLE
    • Sprint:
      Moodle Mobile 3.6.1

      Description

      When we updated Electron to v4, we disabled being able to perform a SSO authentication in the system browser because it caused some problems.

      We should try to restore this feature because it's mandatory for some people.

        Attachments

          Activity

            People

            • Votes:
              3 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                7/Jun/19

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 10 minutes
                10m