Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-2930

The SCORM package doesn't have a visible SCO to load.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.7.0
    • Fix Version/s: 3.7.1
    • Component/s: Android, iOS
    • Labels:
    • Testing Instructions:
      Hide

      This issue only needs to be tested in 1 device.

      1. In the app, login in mobile master and go to MM Dev Testing > SCORM > Link to activity.
      2. Play the SCORM and click the "Proceed" button in the middle.
      3. Go back to the SCORM entry page. Check that you see a checkbox to start a new attempt.
      4. Open the SCORM again without enabling the checkbox. Check that the SCORM is loaded again and no error is displayed.
      Show
      This issue only needs to be tested in 1 device. In the app, login in mobile master and go to MM Dev Testing > SCORM > Link to activity. Play the SCORM and click the "Proceed" button in the middle. Go back to the SCORM entry page. Check that you see a checkbox to start a new attempt. Open the SCORM again without enabling the checkbox. Check that the SCORM is loaded again and no error is displayed.
    • Affected Branches:
      MOODLE_37_STABLE
    • Fixed Branches:
      MOODLE_37_STABLE
    • Sprint:
      Moodle App 3.7.1

      Description

      If in the Learning Management System you set a required status of either passed or complete the issue then occurs on the app. Initially when launching the SCORM on the app, everything works as normal, the SCORM opens and the content begins.

      If you then complete the content, exit the activity and then reopen it again, you get this 'The SCORM package doesn't have a visible SCO to load.' error message (this is the case if you fail the SCORM as well). In order for someone to bypass this message, you have to click the 'Start new attempt' checkbox.

      If however you are incomplete for the SCORM, it works fine and the same goes for 'Not started'.

      I couldn't find anything on the tracker relating to this issue, so I thought I'd raise it.

        Attachments

          Activity

            People

            Assignee:
            dpalou Dani Palou
            Reporter:
            _Kai1401 Kai
            Peer reviewer:
            Pau Ferrer
            Integrator:
            Juan Leyva
            Tester:
            Isabel Renedo Rouco
            Participants:
            Component watchers:
            Juan Leyva, Juan Leyva
            Votes:
            4 Vote for this issue
            Watchers:
            9 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              30/Aug/19