Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-3048

Unable to start quiz on mobile

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Do
    • Affects Version/s: 3.7.0
    • Fix Version/s: None
    • Labels:
    • Affected Branches:
      MOODLE_37_STABLE
    • Sprint:
      Moodle App 3.7.1

      Description

      I have a default clean and empty install of Moodle 3.7 (Build: 20190520) running with nginx 1.16.0, PHP 7.3.5 and MariaDB 10.1.38 and using the latest iOS app. The configuration page is all Green and no warnings.

      I've created a new course and added an exam. I've created a simple question exported to get an idea of the format and then imported 318 question using both Aiken and Moodle XML formats (I had them in plain text so this was the most efficient way).

      I've added all 318 question to the exam, and tried accessing it through the app but I got an error message:

      An error occurred while reading the questions. Please attempt this quiz in a web browser.

      I thought it might be the number of questions so when I tried to delete them all the DB timed out so I had to delete them in batches from the exam. I then created a simple multi choice question and tried again but still got the same issue.

      I tried creating a new user, enrolled it in the Course and again tried but to no avail. I always get this error.

      I do not have anything else enabled than what came out of the box as suggested on the docs page. The logs are not showing any errors:

      The user with id '3' viewed the 'quiz' activity with course module id '2'.
      The web service function 'mod_quiz_view_attempt' has been called.
      The user with id '3' has viewed the attempt with id '4' belonging to the user with id '3' for the quiz with course module id '2'.

      I have no previous experience with Moodle, only with Wordpress, so any help or guidance would be appreciated.

       

      P.S. I haven't noticed until now that 3.7.0 is still "unreleased", but I doubt this could be the issue.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              stoinov Peter Stoinov
              Participants:
              Component watchers:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: