Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-3117

SSO browser fails to open after visting forgotten password/settings page

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 3.7.0
    • Fix Version/s: 3.7.1
    • Component/s: Accounts
    • Labels:
    • Workaround:
      Hide

      Check on any device of you choice.

      Case 1:

      1. Add a site with force logout enabled.
      2. Logout the site.
      3. Enter again (it will show the reconnect screen).
      4. Click on cancel.
      5. Check you are on the list of sites page.

      Case 2:

      You will need a fixed url site configured with login on inapp browser for that (ie. branded).

      1. Enter the app and go to credentials page (first time it will be auto-shown), otherwise click on Add a site button.
      2. Open settings from there and go back.
      3. Check login button opens the browser.
      Show
      Check on any device of you choice. Case 1: Add a site with force logout enabled. Logout the site. Enter again (it will show the reconnect screen). Click on cancel. Check you are on the list of sites page. Case 2: You will need a fixed url site configured with login on inapp browser for that (ie. branded). Enter the app and go to credentials page (first time it will be auto-shown), otherwise click on Add a site button. Open settings from there and go back. Check login button opens the browser.
    • Affected Branches:
      MOODLE_37_STABLE
    • Fixed Branches:
      MOODLE_37_STABLE
    • Pull Master Branch:
    • Sprint:
      Moodle App 3.7.1

      Description

      As shown in the attached video, on our branded app (which is hard-coded to log in to a single server) there is a bug on the login page.

      If a user closes the in-app browser, then clicks "Log in", the browser opens correctly.

      However, if they first visit the settings page (gear icon at the top) or the "Forgotten your useranme and password?" page, then goes back, the "Log in" button stops working and the user is stuck.

      We have reproduced this on Android and iOS.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                30/Aug/19