Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-3368

Required node version in package.json to avoid confusion

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.8.2
    • Fix Version/s: 3.9.0
    • Component/s: Others
    • Labels:
    • Sprint:
      Moodle App 3.9.0

      Description

      I would like to suggest that the required node version is defined in package.json, and be enforce with .npmrc.

      The purpose is to avoid for developers to be using the wrong node version when working on the project. I personally jump quite frequently between projects (and node), and this would definitely be a great help, even more so when the Moodle Mobile required version changes without me noticing.

      Example:

      $ nvm use 12
      Now using node v12.16.0 (npm v6.13.4)
      $ npm run setup
      ...SNIP...
      npm ERR! code ENOTSUP
      npm ERR! notsup Unsupported engine for moodlemobile@3.8.0: wanted: {"node":"11.12.0"} (current: {"node":"12.16.0","npm":"6.13.4"})
      npm ERR! notsup Required: {"node":"11.12.0"}
      npm ERR! notsup Actual:   {"npm":"6.13.4","node":"12.16.0"}
      ...SNIP...
       
      $ nvm use 11.12.0
      Now using node v11.12.0 (npm v6.7.0)
      $ npm run setup
      ...SNIP...
      [12:31:46] Finished 'default' after 261 ms
      

        Attachments

          Activity

            People

            Assignee:
            fred Frédéric Massart
            Reporter:
            fred Frédéric Massart
            Peer reviewer:
            Dani Palou
            Integrator:
            Juan Leyva
            Tester:
            Pau Ferrer
            Participants:
            Component watchers:
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              26/Jun/20