Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-3390

Database URL Field "Forced name for the link" doesn't show in Mobile view

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      This issue only needs to be tested in 1 device.

      1. In Moodle, create a new database activity.
      2. Add 4 URL fields to the database:
        1. One with no autolink and no forced name.
        2. One with autolink and forced name (e.g. [link]).
        3. One with autolink and no forced name.
        4. One with no autolink and forced name (e.g. [link]).
      3. Add these fields to the templates (list, single, add).
      4. Create a database entry, filling the 4 URLs.
      5. In the app, open the database. Check that:
        1. The first URL displays the URL but is not a link (not clickable).
        2. The second URL displays the forced name (e.g. [link]) and is a link (clickable).
        3. The third URL displays the URL and is a link (clickable).
        4. The last URL displays the URL but is not a link (forced name is only applied if autolink is enabled).
      Show
      This issue only needs to be tested in 1 device. In Moodle, create a new database activity. Add 4 URL fields to the database: One with no autolink and no forced name. One with autolink and forced name (e.g. [link] ). One with autolink and no forced name. One with no autolink and forced name (e.g. [link] ). Add these fields to the templates (list, single, add). Create a database entry, filling the 4 URLs. In the app, open the database. Check that: The first URL displays the URL but is not a link (not clickable). The second URL displays the forced name (e.g. [link] ) and is a link (clickable). The third URL displays the URL and is a link (clickable). The last URL displays the URL but is not a link (forced name is only applied if autolink is enabled).
    • Affected Branches:
      MOODLE_38_STABLE
    • Fixed Branches:
      MOODLE_39_STABLE
    • Sprint:
      Moodle App 3.9.0

      Description

      When choosing a name using the "Forced name for a link" setting in the URL field in a Moodle Database activity, the name appears in both the list view and the single view. However, this name is not carried over into the Mobile view. Instead, the mobile view expands the URL.

      See the attached images:

      *note: the CSS I have for the Moodle Database prevents wrapping and overflow, so only part of the URL is showing in this screenshot. However, the URL should not display. The word "[link]" was used for that field.

        Attachments

          Activity

            People

            Assignee:
            dpalou Dani Palou
            Reporter:
            tallthom Thom Rawson
            Peer reviewer:
            Pau Ferrer
            Integrator:
            Juan Leyva
            Tester:
            Noel De Martin
            Participants:
            Component watchers:
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              26/Jun/20