Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-3425

Update required Node version to 11+

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 3.9.2
    • 3.9.3
    • Libraries
    • Hide

      This issue need to be tested in a development environment, not in the app.

      1. In your development environment, use node 12 or 14. If you're using "nvm" you can just do "nvm use 12".
      2. Run "npm install". Check that no error is raised.
      3. Now use node 10 or lower.
      4. Run "npm install". Check that an error is displayed about the Node version.
      Show
      This issue need to be tested in a development environment, not in the app. In your development environment, use node 12 or 14. If you're using "nvm" you can just do "nvm use 12". Run "npm install". Check that no error is raised. Now use node 10 or lower. Run "npm install". Check that an error is displayed about the Node version.
    • MOODLE_39_STABLE
    • MOODLE_39_STABLE
    • Moodle App 3.9.3

    Description

      The latest LTS version of NodeJS is now 12.

      I think we should upgrade to it at soon as possible to benefit of the latest updates.

      Attachments

        Activity

          People

            dpalou Dani Palou
            vaiton VaiTon
            Pau Ferrer Pau Ferrer
            Juan Leyva Juan Leyva
            Pau Ferrer Pau Ferrer
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              30/Nov/20