Details

    • Sub-task
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 3.9.5
    • 4.0.0
    • Performance
    • Hide

      This issue only needs to be tested in 1 device.

      1. Install an older version of the app and login in a 3.1-3.4 site.
      2. Install a version of the app that includes this patch.
      3. Open the app. Check that you're sent to the reconnect screen.
      4. Enter the password and click to login. Check that you see a message saying that the app only supports 3.5 onwards.
      5. Go to add a new site, put the URL of a 3.1-3.4 site.
      6. Enter the credentials and click to login. Check that you see a message saying that the app only supports 3.5 onwards.
      7. Check that you can successfully login in a 3.5 site.
      Show
      This issue only needs to be tested in 1 device. Install an older version of the app and login in a 3.1-3.4 site. Install a version of the app that includes this patch. Open the app. Check that you're sent to the reconnect screen. Enter the password and click to login. Check that you see a message saying that the app only supports 3.5 onwards. Go to add a new site, put the URL of a 3.1-3.4 site. Enter the credentials and click to login. Check that you see a message saying that the app only supports 3.5 onwards. Check that you can successfully login in a 3.5 site.
    • MOODLE_39_STABLE
    • MOODLE_400_STABLE
    • Moodle App 4.0

    Description

      Remove all the unnecesary code required for backwads compatibility

      Attachments

        1. screenshot-3.png
          screenshot-3.png
          158 kB
        2. screenshot-2.png
          screenshot-2.png
          241 kB
        3. screenshot-1.png
          screenshot-1.png
          137 kB

        Activity

          People

            dpalou Dani Palou
            jleyva Juan Leyva
            Pau Ferrer Pau Ferrer
            Pau Ferrer Pau Ferrer
            Juan Leyva Juan Leyva
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              22/Apr/22