Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-3903

Link to a course with self enrol doesn't work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Waiting for testing
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.9.5
    • Fix Version/s: None
    • Component/s: Enrolment
    • Labels:
    • Testing Instructions:
      Hide

      This issue only needs to be tested in 1 device.

      1. In the app, login with the user specified by Isabel in the comment.
      2. Open the course specified in the comment.
      3. Scroll down to the "self enrolment" section.
      4. Click the first link (course/view.php?id=16). Check that the course is opened in the app (the course has guest access). Before this patch, self enrolment had more priority than guest access for course/view.php links, now it behaves like Moodle web.
      5. Go back and now click the next link (course/enrol.php). Check that you see a modal asking for the enrolment key.
      6. Cancel and click the next link (enrol/index.php). Check that you see a modal asking for the enrolment key.
      7. Enter a wrong enrolment key. Check that the modal is displayed again and it says that the password was wrong.
      8. Enter the right enrolment key. Check that the course is opened (it can take a while, for some reason sometimes the WebService takes a while to return the new course after self enrol).
      Show
      This issue only needs to be tested in 1 device. In the app, login with the user specified by Isabel in the comment. Open the course specified in the comment. Scroll down to the "self enrolment" section. Click the first link (course/view.php?id=16). Check that the course is opened in the app (the course has guest access). Before this patch, self enrolment had more priority than guest access for course/view.php links, now it behaves like Moodle web. Go back and now click the next link (course/enrol.php). Check that you see a modal asking for the enrolment key. Cancel and click the next link (enrol/index.php). Check that you see a modal asking for the enrolment key. Enter a wrong enrolment key. Check that the modal is displayed again and it says that the password was wrong. Enter the right enrolment key. Check that the course is opened (it can take a while, for some reason sometimes the WebService takes a while to return the new course after self enrol).
    • Affected Branches:
      MOODLE_39_STABLE
    • Pull Master Branch:
    • Sprint:
      Moodle App 4.0

      Description

      Issue:

      If a user taps on a link to a course with self enrol, a message asquing if they want to enrol appear, but even if they select yes nothing happens

      (It works correctly on browser)

        Attachments

          Activity

            People

            Assignee:
            dpalou Dani Palou
            Reporter:
            isabelrenedo Isabel Renedo Rouco
            Integrator:
            Pau Ferrer Pau Ferrer
            Tester:
            Isabel Renedo Rouco Isabel Renedo Rouco
            Participants:
            Component watchers:
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: