Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-4414

Contact support is hidden when site config is not provided

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • Minor
    • 4.3.0
    • 4.1.1, 4.2.0
    • Log in screen
    • Hide

      This issue should be tested in webapp.

      1. Open the app, go to add a new site and enter any valid site URL.
      2. In the credentials screen click the help button at the top right corner of the screen.
        1. It should open the help modal and show the "Contact support" inside it.
      3. Now try to login with wrong user / pass until appears the error message to contact with support. (it should appear at the 3rd or 4th retry)
      4. Remove &siteCheck=param-<param_id> from the url and add siteUrl=SITEURL (if needed).
      5. In the credentials screen click the help button at the top right corner of the screen.
        1. It should open the help modal and show the "Contact support" inside it.
      6. Try to login with wrong user / pass until appears the error message to contact with support. (it should appear at the 3rd or 4th retry)
      Show
      This issue should be tested in webapp. Open the app, go to add a new site and enter any valid site URL. In the credentials screen click the help button at the top right corner of the screen. It should open the help modal and show the "Contact support" inside it. Now try to login with wrong user / pass until appears the error message to contact with support. (it should appear at the 3rd or 4th retry) Remove &siteCheck=param-<param_id> from the url and add siteUrl=SITEURL (if needed). In the credentials screen click the help button at the top right corner of the screen. It should open the help modal and show the "Contact support" inside it. Try to login with wrong user / pass until appears the error message to contact with support. (it should appear at the 3rd or 4th retry)
    • MOODLE_401_STABLE, MOODLE_402_STABLE
    • MOODLE_403_STABLE
    • Moodle Apps - 2023 Sprint i3.2

    Description

      When the url doesn't contain siteConfig param we are not showing the "Contact support" button in the help modal of credentials page.

      Also, when we fail many login attempts we should be able to see the contact site support error, but it not displayed anyways.

       

      How it should be displayed:

      How its currently displayed:

      Attachments

        Activity

          People

            alfonso.salces@moodle.com Alfonso Salces
            alfonso.salces@moodle.com Alfonso Salces
            Noel De Martin Noel De Martin
            Dani Palou Dani Palou
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Clockify

                Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.