Uploaded image for project: 'Moodle Mobile'
  1. Moodle Mobile
  2. MOBILE-51

native client for Android-based smartphone for Moodle

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Component/s: Android
    • Labels:
    • Database:
      Any
    • Affected Branches:
      MOODLE_10_STABLE

      Description

      We developed a native interface for smartphone based on Android v. 2.2 and v. 2.3 version.
      It implements some basics functions of a Moodle platform for the student role:
      0) login (normal login account)
      1) read the list of your course
      2) see your calendar
      3) see your grades
      4) see the resources (PDF, doc, xls, ppt, txt)
      5) read the forums and reply to a post
      6) see the list of participants
      It relies on the package of OKTech webservice (http://docs.moodle.org/20/en/Web_Services:OK_Tech_Web_Services#Installation).

      If useful, we could share it (it is a joint project of eLab - USI and SUPSI http://www.elearninglab.org/ and Faculty of Informatics at USI http://www.inf.usi.ch/), let us know.
      Best regards,
      Luca (luca.mazzola_AT_usi.ch)

        Gliffy Diagrams

          Attachments

          1. ANDROID_Notifications.png
            ANDROID_Notifications.png
            13 kB
          2. ANDROID_Settings.png
            ANDROID_Settings.png
            28 kB
          3. CourseDetails.png
            CourseDetails.png
            32 kB
          4. CoursesList.png
            CoursesList.png
            15 kB
          5. Dashboard.png
            Dashboard.png
            27 kB
          6. DiscussionAdd.png
            DiscussionAdd.png
            11 kB
          7. DiscussionsList.png
            DiscussionsList.png
            14 kB
          8. DiscussionThreadAddMessage.png
            DiscussionThreadAddMessage.png
            12 kB
          9. DiscussionThreadVisulization.png
            DiscussionThreadVisulization.png
            27 kB
          10. ForumsList.png
            ForumsList.png
            13 kB
          11. Grades.png
            Grades.png
            13 kB
          12. Login.png
            Login.png
            16 kB
          13. ParticipantDetails.png
            ParticipantDetails.png
            20 kB
          14. ParticipantsList.png
            ParticipantsList.png
            22 kB
          15. PersonalCalendar.png
            PersonalCalendar.png
            25 kB
          16. PersonalCalendarEvent.png
            PersonalCalendarEvent.png
            19 kB
          17. ResourcesDownload.png
            ResourcesDownload.png
            25 kB
          18. ResourcesList.png
            ResourcesList.png
            24 kB

            Issue Links

              Activity

              dongsheng Dongsheng Cai added a comment -

              Hi, Luca

              Thanks, I'm very glad to hear there is an android app. I would like to know more details:
              1. is this app available under GPL?
              2. what's the UI look like and is it customizable? because we are planning to use exactly same UI on iPhone and Android.

              I added Martin to watcher, so we can discuss more details

              mazzolal Luca Mazzola added a comment -

              Hi,
              I attach here the screenshots of the app.
              It is also downloadable from:
              http://bit.ly/mmoodle2011

              We are happy to release it as a LGPL software
              Right now the interface is not customizable, but if you like we can see the differences and find a common UI.

              Regards,
              Luca.

              mazzolal Luca Mazzola added a comment -

              Screenshots of the application

              dody1991 doraid magdy added a comment -

              Nice work bro ,, how did u do it? ,, i mean what the tools you have used it ,, iam using eclipse and still dont know how ,, every one make it by using (PHP) ,, and i hate php
              deroowebas@gmail.com
              thats my email , i want contact with you
              Thanxs

              dougiamas Martin Dougiamas added a comment -

              I'm sad we didn't follow this up

              jerome Jérôme Mouneyrac added a comment -

              Hi guys,
              I'm closing this issue as it's not a bug. We are working on a HTML5 app that will use phonegap and work on Android:

              Moodle Mobile (HTML5 iOS/Android/Windows7/...)
              ==============================================
              My Moodle is replaced by Moodle Mobile: http://docs.moodle.org/dev/Moodle_Mobile

              Work in progress: http://tracker.moodle.org/browse/MOBILE-153

              Repository: https://github.com/moodlehq/moodlemobile

              Luca where can we find your app? Did you add it in the Moodle docs? It makes me think we need a Moodle docs that reference all existing apps for Moodle.

              giulio Giulio added a comment -

              Hi Jerome,

              I am the developer of this app and this was part of my bachelor project that I did in 2008. I know I am one year and a half later, but I have just seen the comments.

              Honestly I don't know which is the status of any current native application, but if you are still interested to the app I will be glad to share it. I think it would be great make an update to current android version.

              Giulio


                People

                • Votes:
                  3 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: