Uploaded image for project: 'Moodle app'
  1. Moodle app
  2. MOBILE-559

URL Suffix Requirement Stops Access To Internal Sites Without One

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.3
    • Fix Version/s: 1.4.4
    • Component/s: Accounts
    • Labels:
    • Affected Branches:
      MOODLE_14_STABLE
    • Fixed Branches:
      MOODLE_14_STABLE

      Description

      We have a number of ipads in our organisation that are only used on the intranet. We want to use the mobile app to access our moodle server which is only internal facing and has the url http://e-learning/ no suffix.

      Moodle Mobile will not even try and access a url without a suffix. Seems to think it is an invalid address without one and says "Site URL required, i.e......."

      The ipads can access the server direct through safari and the web service for mobile devices is enabled.

      I think the app is not even checking the URL given and is just throwing a formatting error straight away. Not sure why you need to check for a suffix. Surely just the error for a valid url is enough. For example if I enter http://nomoodlehere.co.uk it will try and look it up but doesn't work. http://nomoodlehere just gives the formatting error.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                12/Jun/14